How do I import mockups to Mockups for Google Drive, Confluence or JIRA?

In Google Drive, Confluence or JIRA you can use export/import to import mockups you've created on your site, or those you saved from elsewhere, for instance Mockups to Go. Here's how you'd do it.


Export#

Export Mockup (from Confluence, JIRA, or Google Drive)
  • Open the mockup and select the menu Mockup > Export Mockup XML.
Export Mockup from a different Balsamiq product

If you use the Desktop app:

  • Export the mockup from the Desktop app using the menu File > Export Mockup XML. The contents are copied to your clipboard.

Note: even if you don't have a paid version of the Desktop app, you can still download and use the trial version to open and export mockup files (after 7 days you can no longer save files, but all other features are fully-functional). This can be a convenient way, for example, to get Mockups to Go libraries into your plugin version.

If you use myBalsamiq:

  • Export the mockup from the menu Project > Export Mockup XML. The contents are copied to your clipboard.

If you don't use the Desktop app or myBalsamiq:

  • Open the mockup from a text editor (like Notepad or or TextEdit) and copy its contents to your clipboard.

Import#

For Confluence or JIRA:

  • Export the Mockup XML from the product you are exporting from (see instructions above)
  • Create a new mockup in your Mockups plugin.
  • When the editor is loaded, use the menu Mockups > Import Mockup XML...
  • Paste the mockup data in the text area and click Import.

Note: To see a demonstration of this process in Confluence see our tutorial on Creating a Mockups Design Library in Confluence.

For Google Drive:


More Import/Export Options#

If you use Google Drive, Confluence or JIRA but don't have a license for one of our Mockups plugins, you can still share your mockups using these products. To do this, upload your mockups as images (go to "File > Export to PNG image" in the Desktop version) and attach or embed the images. You can also upload your Mockups (.bmml) files for other Desktop users to download to their computers.

If you're looking for import/export options for other applications or file formats, a good number of extensions have been written so far. You can find the list of import/export extensions here.

Our BMML format is open and documented.

Last Updated: Jun 18, 2014 11:35AM PDT